Tuesday, November 1, 2016

macos gcc vs clang

localhost:libmad-0.15.1b dc$ /usr/bin/gcc -v
Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/include/c++/4.2.1
Apple LLVM version 8.0.0 (clang-800.0.42.1)


Get errors in mac when compiling c code such as for vlc dependencies which requires gcc.

brew install gcc49

There is list of gcc versions....

No comments:

Post a Comment